태터데스크 관리자

도움말
닫기
적용하기   첫페이지 만들기

태터데스크 메시지

저장하였습니다.
 

 
블로그 이미지
[www.netrain.co.kr]에서 네트워크/보안을 공부하시는 분들을 위해 서비스를 제공하는 블로그입니다 승진아빠
Follow silpir  on Twitter


 
 

[CCIE 360 - LAB #1] Frame-Relay

금주의 LAB | 2010.07.07 11:35 | Posted by 승진아빠

어제는 집안에 일이 있어서 메일링을 작성하지 못했습니다. 별 일은 아니였구요, 5살난 아들놈이 아빠보고 싶다고 계속 울고 있다고 해서 만사 제쳐놓고 집에 가서 아이와 3시간 놀았습니다. ^^

그리고, 몇주간 [네트워크 심화]를 보내드리기로 한 수요일에 메일링을 보내드리지 못했죠? 금주부터는 [네트워크 심화] 시간에 'CCIE 360' 문제를 풀어드리기로 하겠습니다.
생각보다 메일링 서비스를 받는 분들 중에 CCIE를 준비중이신 분들이 많이 계시더라구요.

CCIE를 기 취득하신 분들이나 준비하시고 계신 분들이 다음과 같은 메일을 보내주셨습니다.
'CCIE 준비중인데 메일링을 읽다보니 CCNA도 제대로 몰랐던것 같다'
'CCIE 취득전에 많은 학원에 다녀봤지만, 원리를 설명해 주는 곳은 처음인것 같다'
'CCIE 빨리 따야 해요. 그런데, 돈이 없어요... 도와주세요!'
'어떤 교재보다 메일링 내용이 쉽고 좋은데, CCIE 수준까지 가려면 3년은 메일링을 받아야 할 것 같군요!'

예! 교육비용이 없어서 독학하고 계신 분들이 많으시니 제가 도와드리겠습니다. 그 일환으로 선택한 것이 'CCIE 360'입니다. 시스코에서는 'CCIE 360' 문제를 풀 수 있으면 CCIE 시험에 합격할 수 있다고 말하고 있으니, 메일링을 통해 매주 수요일에 한 문제씩 풀어보도록 하시죠!

금일 한문제를 풀어볼까요?

[구성도]


1. Frame-Relay and Serial Communications Section
1.1 Configure Frame-Relay interface

■ Configure Frame-Relay Physical interfaces wherever possible. otherwise configure point-to-point Frame-Relay interfaces. Supply IPv4 addresses on all required Frame-Relay interfaces according to the "IPv4 IGP" diagram.

1.2 Control the Full Mesh with Static Maps
■ Verify that only the permanent virtual circuits (PVCs) listed on the "IPv4 IGP" diagram are used for user traffic. No dynamic entries are allowed in the Frame-Relay map tables. Verify Layer 3 connectivity

1.3 Verify Layer 3 Connectivity
■ Verify that routes R2, R3 and R4 can ping R1 over their respective Frame-Relay PVCs

1.4 Verify Local Connectivity
■ Verify that all routers can ping all attached same-subnet Frame-Relay IPv4 interfaces including local IPv4 addresses

Frame-Relay 문제군요. 일단, 문제를 정리하는 것이 가장 중요합니다. CCIE 시험은 단어 하나하나가 문제를 풀 수 있는 힌트가 되는 경우가 많거든요. 그럼 문제가 의미하는 것을 파악해 볼까요?

Step 1. 문제 분석
- Physical Interface와 Point-to-point Interface로 구성함 → multipoint를 사용하지 말 것
- 향후에 IGP를 구성하기 위해서 Frame-Relay를 설정함 → Broadcast나 Multicast를 전달하여야 함
- Dynamic MAP은 사용할 수 없음 → Inverse-ARP를 disable 하여야 함
- R1은 R2, R3, R4와 Ping이 되어야 함
- 동일 Subnet에 연결된 모든 장비에 Ping이 되어야 하며 Self Ping이 되어야 함 → Subnet 상에 연결된 모든 IP address에 대해 Map을 설정함

Step 2. Frame-Relay 설계




Step 3. Configuration


■ R1
interface Serial0/0/0
  ip address 172.16.123.1 255.255.255.0
  encapsulation frame-relay
  frame-relay map ip 172.16.123.1 102
  frame-relay map ip 172.16.123.2 102 broadcast
  frame-relay map ip 172.16.123.3 103 broadcast
  no frame-relay inverse-arp
  no shutdown
interface Serial0/0/0.1 point-to-point
  ip address 172.16.14.1 255.255.255.0
  frame-relay interface-dlci 104

■ R2
interface Serial0/0/0
  ip address 172.16.123.2 255.255.255.0
  encapsulation frame-relay
  frame-relay map ip 172.16.123.1 201 broadcast
  frame-relay map ip 172.16.123.2 201
  frame-relay map ip 172.16.123.3 201
  no frame-relay inverse-arp
  no shutdown

■ R3
interface Serial0/0/0
  ip address 172.16.123.3 255.255.255.0
  encapsulation frame-relay
  frame-relay map ip 172.16.123.1 301 broadcast
  frame-relay map ip 172.16.123.2 301
  frame-relay map ip 172.16.123.3 301
  no frame-relay inverse-arp
  no shutdown

■ R4
interface Serial0/0/0
  ip address 172.16.14.4 255.255.255.0
  encapsulation frame-relay
  frame-relay map ip 172.16.14.1 401 broadcast
  frame-relay map ip 172.16.14.4 401
  no frame-relay inverse-arp
  no shutdown

※ TIP
- Frame-Relay Map이 '0.0.0.0'으로 잡힐 경우 reload 해야 하는 경우가 발생할 수 있으므로 'no frame-relay interface-arp' 설정 후 Interface를 enable 하는 것이 좋음
- 직접 연결되어 있지 않은 Interface나 자신의 Interface로 Map을 설정하는 경우는 불필요한 설정으로 간주될 수 있으므로 broadcast option을 사용하지 않음

CCIE Troubleshooting 과연 어려운가? (1)

금주의 LAB | 2010.04.12 08:05 | Posted by 승진아빠


주말에 14시간, 8시간 강의하고... 잠시 쉬는데 등 뒤에 담이 와서 어제는 움직일 수가 없었는데, 오늘 아침은 많이 뻐근한 정도군요. 타자치는데는 아무런 문제가 없을 듯 합니다. ^^ 오늘은 CCIE Troubleshooting 문제때문에 왜 사람들이 많이 걱정하나... 확인해 보도록 하겠습니다.

먼저 구성도는 다음과 같습니다.



Q1. R1 can't establish an OSPF neighbor relationship with R2. Fix this problem so that with R2. Fix the problem so that OSPF neighbor relationship.

■ R1 설정

interface Serial0/0
 ip address 172.14.11.1 255.255.255.248
 encapsulation frame-relay
 ip ospf authentication-key 1 md5 cisco
 ip ospf network point-to-multipoint
 frame-relay map ip 172.14.11.3 315 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco

router ospf 1
 log-adjacency-changes
 area 1 authentication message-digest
 area 1 nssa
 network 172.14.11.1 0.0.0.0 area 1

■ R2 설정

interface Serial0/0
 ip address 172.14.11.3 255.255.255.248
 encapsulation frame-relay
 ip ospf authentication-key 1 md5 cisco
 ip ospf network point-to-multipoint
 frame-relay map ip 172.14.11.1 315 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco

router ospf 1
 log-adjacency-changes
 area 1 authentication message-digest
 area 1 nssa
 network 172.14.11.3 0.0.0.0 area 1

■ FR_Switch

frame-relay switching

interface Serial0/0
 description "Connected to R1 s0/0"
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 315 interface Serial0/1 351

interface Serial0/1
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 315 interface Serial0/0 315

제가 가지고 있는 문제 중 하나는 위와 같군요. 실제 문제가 저렇다면 너무 지저분한 문제죠? 한번 보시죠!
항상 Troubleshooting을 할 때는 Layer 1부터 보시는 것이 좋습니다. 하지만, 시험보다가 'Cable 문제인것 같다'라고 하면 '웃기지 마라'라고 합니다.

그럼, OSPF가 Neighbor가 맺어지지 않는다고 하니... Layer 2부터 봐야 하겠군요.

1. Encapsulation과 Lmi-type은 제대로 설정되었는지 확인 : 문제 없군요.
    - R1 : encapsulation frame-relay, frame-relay lmi-type cisco
    - R2 : encapsulation frame-relay, frame-relay lmi-type cisco
    - FR_Switch : encapsulation frame-relay, frame-relay lmi-type cisco

2. Frame-Relay는 Multi-Access 망이기 때문에 L2 address(DLCI)가 필요하고, L2 address는 L3 address와 MAP이 있어야 합니다. 그리고, Service Provider의 Frame-Relay Swtich는 고객의 DLCI 번호를 보고 본/지점간에 Frame을 Forwarding할 수 있도록 설정되어 있어야 합니다. 확인해 보도록 하시죠!
    - R1 : frame-relay map ip 172.14.11.3 315 broadcast
    - R2 : frame-relay map ip 172.14.11.1 315 broadcast
    - FR_Switch : [R1(s0/0) : 315] → [R2(s0/1) : 351], [R1(s0/0) : 315] → [R2(s0/1) : 315]

※ 일단, 하나를 찾았군요.  R1에서 유입된 DLCI 315번이 R2로 전달시 351번을 달고 나가도록 설정되어 있군요. R2의 DLCI 번호는 315번이기 때문에 당연히 315번을 달아서 내보내야 하죠! ^^
FR_Switch의 's0/0'에서 [frame-relay route 315 interface Serial0/1 315]로 수정

벌써 풀어버렸습니다. 쉬우시죠? 몇가지 더 살표보도록 하시죠.

3. OSPF Network type을 확인
    - R1 : ip ospf network point-to-multipoint
    - R2 : ip ospf network point-to-multipoint

MAP을 잡을 때 broadcast 옵션을 주었으니, NBMA망이 BMA망으로 변경되었군요. 그럼 OSPF network type을 [broadcast]나 [point-to-multipoint]로 바꾸어도 문제가 없겠네요. Frame-relay map 뒤에 broadcast 옵션을 주지 않았다면 저 부분이 틀렸을텐데 안타깝습니다. 하여튼 문제 없습니다.

4. Network command를 확인 : 문제 없군요.
    - R1 :  network 172.14.11.1 0.0.0.0 area 1
    - R2 :  network 172.14.11.3 0.0.0.0 area 1

5. Not-So-Stubby-Area군요. 둘다 설정되어 있는지 확인 : 문제 없군요.
    - R1 :  area 1 nssa
    - R2 :  area 1 nssa

6. Area 1에 인증을 선언하고 Interface에 인증 Password를 설정했군요. 확인해 보시죠!
    - R1/R2 :  area 1 authentication message-digest
    - R1 : ip ospf authentication-key 1 md5 cisco
    - R2 : ip ospf authentication-key 1 md5 cisco

제대로 되었나요? MD5 인증을 하겠다고 선언하고선 Text 기반 Key를 주었군요. 헷갈리게 써 놨지만 [ip ospf authentication-key 1 md5 cisco]라고 선언하면 [1 md5 cisco]가 Password가 되는거죠! ^^ 이런식으로 속이려 하다니, 매우 지저분하군요. 어떻게 바꿔 주셔야 하나요? 그렇죠.. 다음과 같이 바꿔 주셔야죠!
[ip ospf message-digest-key 1 md5 cisco]

휴~ 한문제 풀었군요. Troubleshooting 문제가 8문제인가요? 하지만, 위의 문제를 보시면 아시겠지만, 그리 어렵지는 않습니다. 자신을 가지세요. 저도 타자를 좀 쳤더니 다시 목뒤가 아프기 시작하는군요. 아침 8시군요. 한 20분 산책하면서 근육을 풀어주고 오도록 하겠습니다.

LAB으로 확인하는 BGP update 시간!

금주의 LAB | 2010.04.03 01:00 | Posted by 승진아빠

오늘은 술한잔 하고 들어왔습니다. 세상이 어렵다 보니 본의든 본의가 아니든 회사를 그만두시는 분들이 많으시네요. 그래도 이 업계에서 한시대를 풍미하시던 분들이 한두분씩 퇴직을 하니 마음이 너무 아프군요. 은퇴하시는 대 선배님들을 모시고 대화를 나눌만한 포럼이 하나쯤은 있어야 하지 않나 하는 생각이 드는 우울한 날이군요.

우울한 기분에 빨리 메일링을 쓰고나서 소주한잔 더 빨고 자야겠습니다. 저를 만든 것이 선배님들이고 제가 도와 드려야 하는 분들이 후배님들 아니겠습니까? 혼자 잘나서 설치는 사람들은 Network 엔지니어 자격이 없다는 생각이 강하게 드는 오늘....... 메일링을 시작합니다.

어려분은 Network에 변화가 발생하면 그 정보를 빠르게 동기화 하는 것이 최상이라고 생각하십니까? 세상에 장점만 되는 것과 단점만 되는 것은 없다고 생각합니다. 장점은 단점이 되기도 하고, 단점은 장점이 되기도 합니다. 

BGP라는 Routing Protocol은 오히려 빠르게 동기화 하는 것이 단점이 됩니다. 왜냐구요? BGP는 전세계의 Network 정보를 동기화하는 Routing Protocol입니다. 만일, 특정 Network이 Cable이나 Port 불량으로 UP/DOWN을 반복하여 Network 변화가 자주 발생된다면 엄청난 정보가 전세계에 뿌려지게 되며 불안정해지게 될 것입니다. 그래서 BGP는 update 정보를 batch 형식으로 전달을 합니다. 무슨 말이냐구요?

오늘은 술도 한잔 했겠다, 크게 중요하지 않은 부분이라 제가 강의할 때 구체적으로 설명하지 않는 부분이지만 설명을 해 드리도록 하겠습니다. 내용은 짧고, 이해는 깊게... 화이팅!

한번 LAB을 통하여 확인해 보도록 하겠습니다.
구성도는 다음과 같습니다.


[R1 설정]

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
interface Loopback1
 ip address 11.11.11.11 255.255.255.255
interface FastEthernet0/0
 ip address 10.10.12.1 255.255.255.0
interface FastEthernet1/0
 ip address 10.10.13.1 255.255.255.0
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.10.12.1 0.0.0.0 area 0
 network 10.10.13.1 0.0.0.0 area 0
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 11.11.11.11 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 1
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0
 no auto-summary

[R2 설정]
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
interface Loopback1
 ip address 33.33.33.33 255.255.255.255
interface FastEthernet0/0
 ip address 10.10.23.3 255.255.255.0
interface FastEthernet1/0
 ip address 10.10.13.3 255.255.255.0
router ospf 1
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 10.10.13.3 0.0.0.0 area 0
 network 10.10.23.3 0.0.0.0 area 0
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 33.33.33.33 mask 255.255.255.255
 neighbor 1.1.1.1 remote-as 1
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 2.2.2.2 remote-as 1
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary

[R3 설정]
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
interface Loopback1
 ip address 22.22.22.22 255.255.255.255
interface FastEthernet0/0
 ip address 10.10.12.2 255.255.255.0
interface FastEthernet1/0
 ip address 10.10.23.2 255.255.255.0
interface FastEthernet2/0
 ip address 10.10.24.2 255.255.255.0
router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 10.10.12.2 0.0.0.0 area 0
 network 10.10.23.2 0.0.0.0 area 0
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255
 neighbor 1.1.1.1 remote-as 1
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.1 next-hop-self
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 3.3.3.3 next-hop-self
 neighbor 10.10.24.4 remote-as 2
 no auto-summary

[R4 설정]
interface Loopback1
 ip address 44.44.44.44 255.255.255.255
interface FastEthernet0/0
 ip address 10.10.24.4 255.255.255.0
router bgp 2
 no synchronization
 bgp log-neighbor-changes
 network 44.44.44.44 mask 255.255.255.255
 neighbor 10.10.24.2 remote-as 1
 no auto-summary

자... EBGP와 IBGP로 나누어서 짤막하게 진행해 보도록 하겠습니다.

※ Update 정보를 확인하기 위하여 모든 Router에 'debug ip bgp updates'를 실행해 놓았습니다.

1. EBGP Neighbor의 경우

■ 첫번째 Network 변화 (Shutdown)

R1(config)# interface loopback 1
R1(config-if)# shutdown
Apr  2 00:02:37.635: BGP(0): route 11.11.11.11/32 down : 다운되었군요!
Apr  2 00:02:37.635: BGP(0): no valid path for 11.11.11.11/32
Apr  2 00:02:37.639: BGP(0): 2.2.2.2 send UPDATE 11.11.11.11/32 -- unreachable : 바로 전달하는군요!

R2#
Apr  2 00:02:38.267: BGP(0): 1.1.1.1 rcv UPDATE about 11.11.11.11/32 -- : IBGP로 정보를 받았군요!
Apr  2 00:02:38.275: BGP(0): 10.10.24.4 send unreachable 11.11.11.11/32 : EBGP로 바로 전달하는군요!

Interface를 shutdown 하자 마자 IBGP Neighbor에게 바로 전달을 하고, 그 정보를 받은 Neighbor는 EBGP에게도 바로 전달을 하는군요. 즉, Triggered update가 바로바로 전달되는 것을 확인할 수 있습니다. 그럼, 뭐 OSPF나 EIGRP와 같은 IGP Routing Protocol하고 똑같네요! 그런가요?

예. BGP도 처음 Network 정보가 변경된 경우에는 Triggered Update를 통하여 바로 Network 변경정보를 전달합니다. 바로바로 전달해서 Network 정보를 동기화하는 것이 중요하니까요!

이번에는 한번 Interface를 한번 살려볼까요?

R1(config)# interface loopback 1
R1(config-if)# shutdown
Apr  2 00:02:46.231: BGP(0): route 11.11.11.11/32 up : Down된지 9초 후에 UP이 되었군요!
Apr  2 00:02:46.235: BGP(0): 2.2.2.2 send UPDATE (format) 11.11.11.11/32, next 1.1.1.1, metric 0, path : IBGP로 바로 전달하는군요!

R2#
Apr  2 00:02:47.147: BGP(0): 1.1.1.1 rcvd 11.11.11.11/32 : IBGP로 정보를 받았군요!
Apr  2 00:03:09.199: BGP(0): 10.10.24.4 send UPDATE (format) 11.11.11.11/32, next 10.10.24.2, metric 0, path : EBGP로 22초 후에 정보를 전달하는군요! (22초 + 9초 = 약 30초군요)

R1은 자신의 Interface에 변화가 있을 때, 바로 Triggered Update를 실시하지만,  R2는 EBGP로 정보를 보낼 때 22초나 있다가 전달을 하는군요. 왜 그럴까요? BGP는 Update 정보를 받은 후에 동일한 Network에 대하여 변경된 정보를 30초 이내에 받으면, EBGP로는 첫번째 정보를 받은 후 30초가 지나기 전까지 Update를 하지 않습니다.

보통 쉽게 설명하기 위하여 IBGP로 받은 정보를 EBGP로 넘길 경우 30초의 시간을 대기한다고 하지만, 정확한 설명은 첫번째 Network 변경은 바로 Update를 실시하고, 30초 이내에 동일한 Network에 대해여 변경된 정보를 인지하는 경우에는 30초가 지나기 전에는 Update하지 않는다가 정확한 설명입니다.

중요한 것은 Network의 변화에 바로바로 대응하는 것이 아니라 EBGP는 30초단위로 Network 변화를 Check해서 Update를 함으로써 BGP는 안정성을 우선으로 고려한 Routing Protocol이라는 점입니다.

2. IBGP Neighbor의 경우

R1(config)# interface loopback 1
R1(config-if)# shutdown
Apr  2 00:00:13.755: BGP(0): route 11.11.11.11/32 down : 다운되었군요!
Apr  2 00:00:13.759: BGP(0): 3.3.3.3 send UPDATE 11.11.11.11/32 -- unreachable : 바로 전달하는군요!

R3#
Apr  2 00:00:13.323: BGP(0): 1.1.1.1 rcv UPDATE about 11.11.11.11/32 -- : IBGP로 정보를 받았군요!

역시 EBGP와 마찬가지로 바로 Triggered Update를 실시하는군요.

다시, 살려볼까요?

R1(config)# interface loopback 1
R1(config-if)# no shutdown
Apr  2 00:00:15.831: BGP(0): route 11.11.11.11/32 up : Down된지 2초 후에 UP이 되었군요!
Apr  2 00:00:19.835: BGP(0): 3.3.3.3 send UPDATE (format) 11.11.11.11/32, next 1.1.1.1, metric 0, path
: 4초후에 Update 정보를 전달하는 군요! (2초 + 4초 = 6초군요)

R3#
Apr  2 00:00:19.235: BGP(0): 1.1.1.1 rcvd UPDATE w/ attr: nexthop 1.1.1.1, origin i, localpref 100, metric 0

첫번째 Network 변화가 발생한 경우에는 바로 Triggered Update를 실시하지만, EBGP와 마찬가지로 Network 변화가 자주 일어나니까 첫번째 변화가 있었던 시점에서 부터 일정한 시간이 지나야 Network이 변경되었다는 정보를 전달한다는 사실을 아실 수 있습니다. 그 시간이 5초랍니다.
왜 6초가 되었냐구요? 저에게 BGP 배우신 분은 아시죠... ^^

오늘의 숙제입니다. IBGP도 그렇고 EBGP도 그렇고 30초, 5초로 알고 있는데 왜 1초 정도가 더 추가되었을 까요?

보통 강의할 때는 'BGP는 매번 Triggered Update를 하지 않으며 이유는 안정성 때문이다.' 라는 수준에서 강의를 하는데.. 술이 웬수입니다. 오늘은 KT와 같은 Service Provider에서 강의할 때 설명하는 수준의 깊이였던거 같습니다. 너무 어려워 하지는 마시고요... 궁금하신게 있으면 언제든지 물어보세요.

EIGRP - Neighbor간 subnet이 다르면?

금주의 LAB | 2010.03.23 09:26 | Posted by 승진아빠

어제 저희 직원 중 한명이 몸이 좋지 않다고 병원에 갔는데, 병원에서 지금 당장 수술을 해야 한다고 하더랍니다. 그래서, 3시 20분에 병원에 가서 3시 40분에 수술을 하고 현재 입원중입니다. 모두가 저 때문입니다. 너무 가슴이 아프군요! 너무 일을 많이 시키는게 아닌데...... 하는 생각이 듭니다.

 

어제 수술을 했는데 너무 심해서 두 달 뒤에 다시 수술을 해야 한다는군요. 얼마나 많이 아플까요... 너무 오래동안 앉아서 일하느라 걸린 병입니다. 의사가 어떻게 이렇게 될 때 까지 참고 있었냐고 했답니다. 엄청나게 심해진 치질! 2년전부터 참아 왔는데, 견딜만 했었는데... 저 때문에 심해진겁니다. 일도 적당히 시켜야 겠어요.

 

치질이 얼마나 고통스러운지 걸려보지 않은 사람은 모른다고 하더군요. 그래서, 저도 모릅니다. 그래서, 안타깝습니다. 수술했던 의사는 그 고통을 알고 있을까요? 고통을 알고 있다면 더욱 조심스럽게 수술하기 위해 노력 했겠죠! 갑자기 그런 생각이 드는군요. '제가 엔지니어 생활을 하지 않았다면.....'하는 생각이요.

 

이론은 원리원칙에 의해 만들어지고, 책은 보편타당성에 의해 쓰여 집니다. 현실은요? 현실은 예기치 않은 사건의 연속으로 구성되어 있죠! 파란불에 길을 건넌다고 교통사고 안나는거 아니고, 회사에 충성한다고 진급하는거 아니죠! 제가 엔지니어를 하지 않았다면, '파란불에 횡단보도를 건너면 사고나지 않는다'고만 알고 있을 겁니다. 책에 그렇게 쓰여 있으니까요. 즉, 책읽고 많이 안다고 강의하고 있을 겁니다. 소히, [죽은 강의]라고 하죠!

 

제가 엔지니어 생활을 했었기 때문에 살아 숨쉬는 강의는 아니라 할지라도 '죽은 강의'는 하지 않을 수 있지 않았나 생각이 듭니다. 치질에 걸린 그 친구는 앞으로는 친구가 치질에 걸렸다면 웃지 않고, 친구의 고통과 안타까움이 먼저 생각날겁니다. 만일, '똥침'을 한다면요? ^^

 

여러분도 주위에서 네트워크 기초를 물어보면 자신이 몰랐던 시절을 생각하고, 친절하게 알려주세요. 몰라서 물어보는거 쉬운거 같지만, 용기 없는 사람은 절대 묻지 않습니다. 혼자 네이버에서 찾아보겠죠... 모르는걸 물어보는 사람은 반드시 성공합니다. 제가 확신합니다. ^^

 

자 서론이 길었습니다. 12시 넘으니 정신이 혼미해져서 그래요. 오늘 내용은 네트워크 입문하시는 분들께는 약간 어려운 내용일 수 있습니다. 이런게 있구나... 하면서 편하게 읽어주세요!

 

오늘은 EIGRP에서 Dircet Connect 되어 있는 두대의 Router에서 Subnet을 잘못 줬을 때, 무슨 일이 일어나는지 확인해 보도록 하겠습니다.

 

자 구성도는 다음과 같습니다.

 

 

■ R1

interface FastEthernet0/0
 ip address 12.12.12.1 255.255.255.0

interface FastEthernet1/0
 ip address 1.1.1.1 255.255.255.0

router eigrp 10
 network 1.0.0.0
 network 12.0.0.0
 no auto-summary

 

■ R2

interface FastEthernet0/0
 ip address 12.12.12.2 255.255.0.0

interface FastEthernet1/0
 ip address 2.2.2.2 255.255.255.0

router eigrp 10
 network 2.0.0.0
 network 12.0.0.0
 no auto-summary

 

Routing table을 한번 볼까요?

 

■ R1

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet1/0
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/30720] via 12.12.12.2, 00:01:56, FastEthernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/0

 

■ R2

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/30720] via 12.12.12.1, 00:02:23, FastEthernet0/0
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, FastEthernet1/0
     12.0.0.0/16 is subnetted, 1 subnets
C       12.12.0.0 is directly connected, FastEthernet0/0

 

흠... R1은 '12.12.12.1/24', R2는 '12.12.12.2/16' 서로간에 Subnet mask가 다른데도 Neighbor를 맺고 Route 정보도 잘 전달하는군요. 왜 그럴까요?

 

Routing Protocol 종류가 많죠? RIP, IGRP, EIGRP, OSPF, ISIS, BGP 등... 이러한 Routing Protocol 중 둘 사이에 Subnet이 다르면 Neighbor 관계를 맺지 않는 Routing Protocol은 OSPF 밖에 없습니다. RIP, IGRP, EIGRP과 같은 Distance-Vector Routing Protocol은 다음의 조건만 만족하면 Route 정보를 update 합니다.

 

조건 1 : [R1 Interface의 IP address] < [R2 Interface의 Network]
조건 2 : [R2 Interface의 IP address] < [R1 Interface의 Network]

※ OSPF는 Hello Packet에 Subnet 정보를 전달하여 서로 다르면 Neighbor를 맺지 않습니다.

 

자세한 이론은 오늘의 이론을 통하여 설명하기로 합니다. 토요일은 'LAB으로 배우는 Network' 시간이니까요...^^ 그럼, 위의 조건을 만족하는지 볼까요?

 

조건 1 : 12.12.12.1 < 12.12.0.0/16
조건 2 : 12.12.12.2 < 12.12.12.0/24

 

만족하는군요. 그래서, 아무문제 없이 Route 정보를 전달할 수 있는 겁니다. 잉? 그럼 이게 끝인가요? 설마요. 이걸로 끝이면 메일링 서비스 거부 당합니다. ^^

 

아무 문제없던 Network에 한놈이 다음과 같이 새롭게 연결되었습니다.

 

 

 

■ R1

interface FastEthernet2/0
 ip address 13.13.13.1 255.255.255.0

router eigrp 10
 network 13.0.0.0

 

■ R2

interface FastEthernet2/0
 ip address 23.23.23.2 255.255.255.0

router eigrp 10
 network 23.0.0.0

 

■ R3

interface FastEthernet0/0
 ip address 13.13.13.3 255.255.255.0

interface FastEthernet1/0
 ip address 23.23.23.3 255.255.255.0

router eigrp 10
 network 12.0.0.0
 network 23.0.0.0
 no auto-summary

 

Routing table을 한번 볼까요?

 

■ R1

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet1/0
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/30720] via 12.12.12.2, 00:00:46, FastEthernet0/0
     23.0.0.0/24 is subnetted, 1 subnets
D       23.23.23.0 [90/30720] via 13.13.13.3, 00:00:46, FastEthernet2/0
                   [90/30720] via 12.12.12.2, 00:00:46, FastEthernet0/0
     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       12.12.0.0/16 [90/33280] via 13.13.13.3, 00:00:46, FastEthernet2/0
C       12.12.12.0/24 is directly connected, FastEthernet0/0
     13.0.0.0/24 is subnetted, 1 subnets
C       13.13.13.0 is directly connected, FastEthernet2/0

 

■ R2

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/30720] via 12.12.12.1, 00:01:04, FastEthernet0/0
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, FastEthernet1/0
     23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, FastEthernet2/0
     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       12.12.0.0/16 is directly connected, FastEthernet0/0
D       12.12.12.0/24 [90/33280] via 23.23.23.3, 00:01:04, FastEthernet2/0
     13.0.0.0/24 is subnetted, 1 subnets
D       13.13.13.0 [90/30720] via 23.23.23.3, 00:01:05, FastEthernet2/0
                   [90/30720] via 12.12.12.1, 00:01:05, FastEthernet0/0

 

■ R3

     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/30720] via 13.13.13.1, 00:01:20, FastEthernet0/0
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/30720] via 23.23.23.2, 00:01:20, FastEthernet1/0
     23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, FastEthernet1/0
     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       12.12.0.0/16 [90/30720] via 23.23.23.2, 00:06:09, FastEthernet1/0
D       12.12.12.0/24 [90/30720] via 13.13.13.1, 00:01:20, FastEthernet0/0
     13.0.0.0/24 is subnetted, 1 subnets
C       13.13.13.0 is directly connected, FastEthernet0/0

 

처음에는 이상없어 보입니다... 그러다 조금 기다리시면 R1과 R2에 다음과 같은 메세지가 주기적으로 올라옵니다.

 

■ R1

%DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 12.12.12.2 (FastEthernet0/0) is down: Interface Goodbye received

%DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 12.12.12.2 (FastEthernet0/0) is up: new adjacency

 

■ R2

%DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 12.12.12.1 (FastEthernet0/0) is down: retry limit exceeded

%DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 12.12.12.1 (FastEthernet0/0) is up: new adjacency

 

흠... Neighbor관계를 끊었다 다시 맺었다를 반복하는군요.
그러면, Routing table 정보은 어떻게 변해 있을까요?

 

■ R1

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet1/0
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/33280] via 13.13.13.3, 00:01:41, FastEthernet2/0
     23.0.0.0/24 is subnetted, 1 subnets
D       23.23.23.0 [90/30720] via 13.13.13.3, 00:01:41, FastEthernet2/0
     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       12.12.0.0/16 [90/33280] via 13.13.13.3, 00:02:59, FastEthernet2/0
C       12.12.12.0/24 is directly connected, FastEthernet0/0
     13.0.0.0/24 is subnetted, 1 subnets
C       13.13.13.0 is directly connected, FastEthernet2/0

 

R1에는 12.12.12.2를 Next-hop으로 보는 정보가 다 사라졌군요.

 

■ R2

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/33280] via 23.23.23.3, 00:04:49, FastEthernet2/0
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, FastEthernet1/0
     23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, FastEthernet2/0
     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       12.12.0.0/16 is directly connected, FastEthernet0/0
D       12.12.12.0/24 [90/33280] via 23.23.23.3, 00:06:06, FastEthernet2/0
     13.0.0.0/24 is subnetted, 1 subnets
D       13.13.13.0 [90/30720] via 23.23.23.3, 00:04:49, FastEthernet2/0

 

R2 역시 12.12.12.1을 Next-hop으로 보는 정보가 다 사라졌군요.

왜 이런 현상이 일어나는 걸까요? 우리가 좋아하는 Debug를 한번 걸어봐야 겠군요.

 

■ R1 (debug eigrp packet)

EIGRP: Sending UPDATE on FastEthernet0/0 nbr 12.12.12.2
EIGRP: Received UPDATE on FastEthernet0/0 nbr 12.12.12.2
EIGRP: Sending UPDATE on FastEthernet0/0 nbr 12.12.12.2, retry 1, RTO 3000
EIGRP: Received UPDATE on FastEthernet0/0 nbr 12.12.12.2
EIGRP: Sending UPDATE on FastEthernet0/0 nbr 12.12.12.2, retry 2, RTO 4000
EIGRP: Received UPDATE on FastEthernet0/0 nbr 12.12.12.2
EIGRP: Sending UPDATE on FastEthernet0/0 nbr 12.12.12.2, retry 3, RTO 5000
EIGRP: Received UPDATE on FastEthernet0/0 nbr 12.12.12.2
................
EIGRP: Sending UPDATE on FastEthernet0/0 nbr 12.12.12.2, retry 16, RTO 5000

%DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 12.12.12.2 (FastEthernet0/0) is down: Interface Goodbye received

 

■ R2 (debug eigrp packet)

EIGRP: Sending UPDATE on FastEthernet0/0 nbr 12.12.12.1
EIGRP: Sending UPDATE on FastEthernet0/0 nbr 12.12.12.1, retry 1, RTO 3000
EIGRP: Sending UPDATE on FastEthernet0/0 nbr 12.12.12.1, retry 2, RTO 4000
EIGRP: Sending UPDATE on FastEthernet0/0 nbr 12.12.12.1, retry 3, RTO 5000
................
EIGRP: Sending UPDATE on FastEthernet0/0 nbr 12.12.12.1, retry 16, RTO 5000

%DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 12.12.12.1 (FastEthernet0/0) is down: Interface Goodbye received

 

R1과 R2가 둘다 UPDATE Packet을 보내는데, 상대방이 잘 받았다는 ACK가 오지 않으니까 16번을 다시 던지는군요. 근데, 16번 다시 시도를 했는데 응답이 없으니, Neighbor 관계를 끊어 버리네요. 왜 그럴까요?

그 이유는 다음과 같은 특성때문에 그럽니다.

 

1. Routing Protocol 최우선순위 - 'Longest Match'
2. EIGRP의 UPDATE Packet - Unicast로 전송
3. EIGRP는 받은 UPDATE Packet의 Source IP address가 Neighbor IP address가 아니면 무시함
4. EIGRP는 UPDATE를 던지고 ACK를 받지 못하면 16번 Retry를 실시하고 Neighbor를 끊음

 

자, 다시 아까전의 Routing table을 한번 보세요.

 

R2의 Nighbor가 누구일까요? 바로 '12.12.12.1' 일겁니다.

 

R2# show ip eigrp nei
IP-EIGRP neighbors for process 10
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
0   12.12.12.1              Fa0/0             13 00:00:56    1  5000  1  0
1   23.23.23.3              Fa2/0             10 00:31:45  246  1476  0  11

 

그러면, UPDATE Packet을 던지기 위해 12.12.12.1에게 전송을 하겠군요.
그럼, Routing table을 한번 확인 해 보시죠!

 

R2# show ip route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/33280] via 23.23.23.3, 00:26:43, FastEthernet2/0
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, FastEthernet1/0
     23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, FastEthernet2/0
     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       12.12.0.0/16 is directly connected, FastEthernet0/0
D       12.12.12.0/24 [90/33280] via 23.23.23.3, 00:28:01, FastEthernet2/0
     13.0.0.0/24 is subnetted, 1 subnets
D       13.13.13.0 [90/30720] via 23.23.23.3, 00:26:44, FastEthernet2/0

 

'12.12.12.0/24'가 '23.23.23.3'으로 잡혀 있군요. 그럼 Fa2/0으로 UPDATE Packet을 전송하겠군요. 자신의 Interface는 16bit이니 24bit인 찾아가겠죠! 이해가 안가시면 기존 메일링에서 Longest match 부분을 확인하세요.

 

자, 다음이 문제입니다. '12.12.12.1'에게 UPDATE Packet을 전송하기 위해 Fa2/0 Interface로 Packet을 전송하게 되면, Router는 Outgoing interface의 IP address가 Default로 Source IP address가 되기 때문에 Source IP address가 '23.23.23.2'로 날아가게 될겁니다.

 

그런데, R1이 그 정보를 받으면 '23.23.23.2'는 자신의 Neighbor IP address가 아니기 때문에 UPDATE 정보를 무시하겠죠? 그러니, 무슨 ACK를 보내겠습니까..... R2는 R1이 무시하는줄도 모르고 16번 Retry 하닥 Neighbor를 끊게 되는거랍니니다.

 

휴~ 오늘은 양이 많군요. 그럼 여기서 2가지 문제를 드릴테니 한번 생각해 보세요.

 

1. 왜 Neighbor는 다시 맺는걸까요?
2. 왜 23.23.23.3이 Best가 되었을까요?

 

오늘은 네트워크 입문 단계이신 분들에게는 조금 까다로운 문제였죠? 월~수에 진행하는 오늘의 이론을 잘 따라오시면 이런건 아무것도 아니랍니다. 겨우 이런게 CCIE Ended에 나와요... 알면 아무것도 아니죠. 오늘 하루도 수고하셨습니다. 감사합니다.

[Floating Routing]의 이해와 한계점

금주의 LAB | 2010.03.23 09:24 | Posted by 승진아빠

그런 기분 아시나요? 오늘 저희 회사가 국내 1위 VAN 사 Network 컨설팅을 요청받아서 자료를 받아 왔습니다. 스위스저축은행 차세대 ISP와 함께 진행하면 저와 우리 직원들 다 과로로 쓰러질거 알지만, 학원 운영비가 장난이 아니라서 유지하기 위해 뭐든지 받아와야 하거든요. 이번달에만 컨설팅 의뢰가 4개 들어왔는데, 2개는 OK했고 나머지는 아직 OK하지 않았습니다. 

 

기술력만 있으니 컨설팅만 들어오네요. 영업사원 없는 학원은 정말 불가능한 걸까요? 저희도 다른 학원처럼 스폰서 잡고 알바시켜서 여기저기 쪽지 보내고, 아무나 수강생 데리고 오면 10~20% 주는 전 국민 영업사원화를 해야 할까요? ^^ 오늘 저녁 메일링을 쓰면서 고민해 봅니다.

 

오늘은 Floating Routig에 대해 LAB을 진행해 보겠다고 했었죠? 영어로 해석하면 '유동적인 경로'죠!
즉, 상황에 따라 사라졌다 나타나 하는 경로를 이야기 합니다. 재미있는 기술인 것 같죠? 오늘은 Floating Routing LAB에 대해 설명을 드리고, Floatng Routing 기술의 한계점에 대해 문제를 드리도록 하겠습니다.

다음과 같은 토폴로지에서 R3는 R1을 Main으로 사용하다, R1 경로에 이상이 생길 경우 R2로 Packet을 전송하려고 합니다. 그래서, 다음과 같이 Static route를 설정했습니다.

 


R3(config)# ip route 192.168.12.0 255.255.255.0 fa0/0 192.168.13.1
R3(config)# ip route 192.168.12.0 255.255.255.0 fa1/0 192.168.23.2


그런데 이렇게 설정하면 R3에 어떻게 표시가 될까요? 그렇습니다. 다음과 같이 나타날겁니다.

S    192.168.12.0/24 [1/0] via 192.168.23.2, FastEthernet1/0
                            [1/0] via 192.168.13.1, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet0/0
C    192.168.23.0/24 is directly connected, FastEthernet1/0


그럼, 어떻게 해야 FastEthernet0/0을 우선하게 만들 수 있을가요?
아직, [일일학습]에서 배우시지 않으셨지만, Router는 Best-Path를 결정할 때, Routing Protocol마다 'Administrative Distance'라는 것을 가지고 우선순위를 정합니다. 지난주에 학습하셨던 Longest match 다음 순서죠!

Administrative Distance 값은 Vendor마다 다르니까 너무 외우려고 하지는 마세요. 공통점은 값이 낮을 수록 우선하고, Default로 Connect가 1순위, Static route가 2순위라는 겁니다. 그냥 우리가 시스코에 익숙해져 있어 시스코의 Administative Distane 값을 기억하고 있는 것 뿐이조. 마치 정답인것 처럼요...^^ 자세한건 [일일학습]에서 설명드리겠습니다. 오늘은 LAB으로 배우는 시간이니까요.

Static route는 다른 Dynamic Routing Protocol보다 우선순위를 높여 놨습니다. 당연하겠죠! 관리자가 임의대로 정하는 값이니까요. 그리고, Administrative Distance 값은 Connect를 제외하고, Routing Protocol마다 값을 변경할 수 있는 명령어를 만들어 놓았습니다. Static route도 마찬가지겠죠? 뒤에 Option으로 만들어 놓았습니다.
그걸 한번 바꾸어 볼까요? 다음과 같이요...

R3(config)# ip route 192.168.12.0 255.255.255.0 fa0/0 192.168.13.1
R3(config)# ip route 192.168.12.0 255.255.255.0 fa1/0 192.168.23.2 250

그리고, Routing table을 다시 보면,

S    192.168.12.0/24 [1/0] via 192.168.13.1, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet0/0
C    192.168.23.0/24 is directly connected, FastEthernet1/0


250으로 준 경로는 사라졌습니다. 어디로 갔을까요? 192.168.13.1로 준 경로는 Administrative Distance 값이 '1'이기 때문에 그놈한테 져서 숨어 있는겁니다. 그럼, 그놈이 없어지면 다시 살아날까요? 엔지니어는 생각할 시간이 없습니다. 해보고 눈으로 확인하는 것이 최고의 기술습득 방법입니다. 죽여보죠!! 그렇다고 고객사 가서 죽여보지는 마시고요....

R3(config)# int fa0/0
R3(config-if)# shutdown
R3(config-if)# end
R3# show ip route


S    192.168.12.0/24 [250/0] via 192.168.23.2, FastEthernet1/0
C    192.168.23.0/24 is directly connected, FastEthernet1/0


살아났군요. 자, 이렇게 우리는 Administrative Distance 값을 이용하여 backup 경로를 설정하는 것을 'Floating Routing'이라고 합니다. 대부분 Static route를 이용하여 만들죠. 그럼, 왜 사용할까요? 잘 생각해보면 OSPF나 EIGRP를 사용하면서 Metric 값을 이용해서 Backup 경로를 만들어도 되잖아요.

다음과 같이요. 방금전과 같은 토폴로지에서 모두 OSPF를 올리는 겁니다.
그리고, OSPF는 default 환경에서 100Mbps를 Cost 값 '1'로 계산하니까 Fa1/0을 백업경로로 만들기 위해 Cost를 10으로 인식하도록 바꿉니다.

R3(config)# int fa1/0
R3(config-if)# ip ospf cost 10

R3(config-if)# end
R3# show ip route

그러면, 결과는 다음과 같습니다.


O    192.168.12.0/24 [110/2] via 192.168.13.1, 00:00:44, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet0/0
C    192.168.23.0/24 is directly connected, FastEthernet1/0


Fa1/0 경로가 없어졌죠? 아까와 마찬가지로 fa0/0을 죽여볼까요?

R3(config)#int fa0/0
R3(config-if)# shutdown
R3(config-if)# end
R3# show ip route


O    192.168.12.0/24 [110/11] via 192.168.23.2, 00:00:05, FastEthernet1/0
C    192.168.23.0/24 is directly connected, FastEthernet1/0


살아났네요. 똑같죠? 그런데, 왜 Floating Routing을 사용할까요? 백업경로에 Routing Protocol을 돌릴 수 없는 경우에 많이 사용합니다. 주 회선은 전용회선이고, 백업회선은 Broadband회선(ADSL, Cable 등)을 이용한 VPN 구성으로 되어 있는 경우가 대표적인 예입니다. (GRE over IPsec 쓰면 된다고 하지 마세요. 늦게 따라 오시는 분들도 많으니까 우리 너무 앞서가지 말고 천천히 가시자고요! ^^)

Floating Routing... 좀 이해가 가셨나요?
지금까지 제가 LAB을 진행했다면, 이번에는 여러분이 제 문제를 푸실 시간입니다.

다음과 같은 상황이라면 무슨 문제가 발생하고, 그 원인은 무엇일까요? 지난주 심화과정의 Static route에 대한 부분을 읽어보시면 이해가 가시리라 생각됩니다. 지난 메일을 어떻게 읽을 수 있냐고 질문을 하시더라고요. 메일링 윗부분에 지난 메일링을 볼 수 있도록 되어 있잖아요...^^

(Hint : R1의 fa0/0 Interface가 down 된 경우 발생하는 문제점)

 



R3(config)# ip route 0.0.0.0 0.0.0.0 192.168.123.1
R3(config)# ip route 0.0.0.0 0.0.0.0 192.168.123.2 250
R3# show ip route


C    192.168.123.0/24 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 192.168.123.1


좋은 주말 되시기를... 다음주 월요일에 뵙도록 하겠습니다. 절 보고 싶으시면 학원에 찾아오시면 되요. 저희 학원은 언제든지 열려 있으니까요. ^^


[Longest match]의 이해

금주의 LAB | 2010.03.23 01:44 | Posted by 승진아빠

안녕하세요. 첫 LAB 시간이 되겠군요.
간단한 LAB부터 CCIE 수준가지 한번 달려가 보도록 하시죠. ^^

오늘은 Router의 동작원리를 쉽게 이해할 수 있는 LAB을 진행해 볼까 합니다.

Router가 Best-Path를 찾는 순서 중 가장 우선순위가 높은걸 뭘까요?

[Longest Match]입니다.


뭐가 Long이죠? Subnet의 길이죠! 왜 Subnet의 길이가 긴걸 우선할까요? 예를 들어, 친구 두명한테 전화를 해서 "서울시청"이 어디냐고 물었습니다. 한 친구는 "중구에 있어..." 라고 설명을 해줬고, 다른 친구는 "1호선 전철역 5번출구로 나가면 바로 있어"라고 설명해 줬습니다. 당연히 '1호선 전철역 5번출구'라는 상세 정보를 전달해준 친구를 더 신뢰하겠죠. 10.1.1.1로 가는 Packet에 대해서 '10.0.0.0/8' 정보와 '10.1.1.0/24' 중 누굴 신뢰하겠습니까? 당연히 더 자세한 정보인 '10.1.1.0/24'를 신뢰할 것입니다.
즉, Subnet의 길이가 길다라는 것은 더 작은 Network 정보라는 것이고, 다 작다라는 의미는 더 자세하고 정확한 정보라는 의미가 되는 것이죠.

오늘은 이 Longest Match를 한번에 이해할 수 있는 LAB을 진행해 보도록 하겠습니다.  

■ 구성도



■ R1 Configuration

interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
no shutdown

router eigrp 100
network 10.0.0.0

■ R2 Configuration

interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
no shutdown

interface FastEthernet1/0
ip address 10.2.2.2 255.255.255.0
no shutdown

interface FastEthernet2/0
ip address 10.10.10.1 255.255.0.0
no shutdown

router eigrp 100
network 10.0.0.0

■ R3 Configuration

interface FastEthernet0/0
ip address 10.2.2.3 255.255.255.0
no shutdown

interface FastEthernet1/0
ip address 10.10.10.2 255.255.255.0
no shutdown

router eigrp 100
network 10.0.0.0

■ R1의 Routing table

    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D       10.10.0.0/16 [90/30720] via 10.1.1.2, 00:20:45, FastEthernet0/0
D       10.10.10.0/24 [90/33280] via 10.1.1.2, 00:18:42, FastEthernet0/0
D       10.2.2.0/24 [90/30720] via 10.1.1.2, 00:20:45, FastEthernet0/0
C       10.1.1.0/24 is directly connected, FastEthernet0/0

■ R2의 Routing table

    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       10.10.0.0/16 is directly connected, FastEthernet2/0
D       10.10.10.0/24 [90/30720] via 10.2.2.3, 00:19:10, FastEthernet1/0
C       10.2.2.0/24 is directly connected, FastEthernet1/0
C       10.1.1.0/24 is directly connected, FastEthernet0/0

■ R3의 Routing table

    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D       10.10.0.0/16 [90/30720] via 10.2.2.2, 00:20:42, FastEthernet0/0
C       10.10.10.0/24 is directly connected, FastEthernet1/0
C       10.2.2.0/24 is directly connected, FastEthernet0/0
D       10.1.1.0/24 [90/30720] via 10.2.2.2, 00:20:42, FastEthernet0/0

자! 설정과 확인이 끝났습니다.

여기서 R1에서 10.10.10.1로 Ping을 시도해 볼까요?

R1# ping 10.10.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

헉.. 안가네요. R2에서 시도해 볼까요?

R2# ping 10.10.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

허거덕! 자신의 Interface인데 Ping이 안가네요. 그럼 10.10.10.2로는 Ping이 갈까요?

R1# ping 10.10.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/112/184 ms

R2# ping 10.10.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/59/112 ms

흠... R1과 R2에서 정상적으로 Ping이 되는군요.
왜 이런 현상이 발생할까요? 멍청한 R2는 자신의 Interface로도 Ping을 보내지 못하고 있습니다.
정답은 월요일 메일링에서 상세한 설명과 함께 보내드리도록 하겠습니다. 고민해보세요! ^^

오늘의 LAB 문제를 마치도록 하겠습니다.