태터데스크 관리자

도움말
닫기
적용하기   첫페이지 만들기

태터데스크 메시지

저장하였습니다.
 

 
블로그 이미지
[www.netrain.co.kr]에서 네트워크/보안을 공부하시는 분들을 위해 서비스를 제공하는 블로그입니다 넷트레인
Follow silpir  on Twitter


[Longest match]의 이해

금주의 LAB | 2010.03.23 01:44 | Posted by 넷트레인

안녕하세요. 첫 LAB 시간이 되겠군요.
간단한 LAB부터 CCIE 수준가지 한번 달려가 보도록 하시죠. ^^

오늘은 Router의 동작원리를 쉽게 이해할 수 있는 LAB을 진행해 볼까 합니다.

Router가 Best-Path를 찾는 순서 중 가장 우선순위가 높은걸 뭘까요?

[Longest Match]입니다.


뭐가 Long이죠? Subnet의 길이죠! 왜 Subnet의 길이가 긴걸 우선할까요? 예를 들어, 친구 두명한테 전화를 해서 "서울시청"이 어디냐고 물었습니다. 한 친구는 "중구에 있어..." 라고 설명을 해줬고, 다른 친구는 "1호선 전철역 5번출구로 나가면 바로 있어"라고 설명해 줬습니다. 당연히 '1호선 전철역 5번출구'라는 상세 정보를 전달해준 친구를 더 신뢰하겠죠. 10.1.1.1로 가는 Packet에 대해서 '10.0.0.0/8' 정보와 '10.1.1.0/24' 중 누굴 신뢰하겠습니까? 당연히 더 자세한 정보인 '10.1.1.0/24'를 신뢰할 것입니다.
즉, Subnet의 길이가 길다라는 것은 더 작은 Network 정보라는 것이고, 다 작다라는 의미는 더 자세하고 정확한 정보라는 의미가 되는 것이죠.

오늘은 이 Longest Match를 한번에 이해할 수 있는 LAB을 진행해 보도록 하겠습니다.  

■ 구성도



■ R1 Configuration

interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
no shutdown

router eigrp 100
network 10.0.0.0

■ R2 Configuration

interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
no shutdown

interface FastEthernet1/0
ip address 10.2.2.2 255.255.255.0
no shutdown

interface FastEthernet2/0
ip address 10.10.10.1 255.255.0.0
no shutdown

router eigrp 100
network 10.0.0.0

■ R3 Configuration

interface FastEthernet0/0
ip address 10.2.2.3 255.255.255.0
no shutdown

interface FastEthernet1/0
ip address 10.10.10.2 255.255.255.0
no shutdown

router eigrp 100
network 10.0.0.0

■ R1의 Routing table

    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D       10.10.0.0/16 [90/30720] via 10.1.1.2, 00:20:45, FastEthernet0/0
D       10.10.10.0/24 [90/33280] via 10.1.1.2, 00:18:42, FastEthernet0/0
D       10.2.2.0/24 [90/30720] via 10.1.1.2, 00:20:45, FastEthernet0/0
C       10.1.1.0/24 is directly connected, FastEthernet0/0

■ R2의 Routing table

    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       10.10.0.0/16 is directly connected, FastEthernet2/0
D       10.10.10.0/24 [90/30720] via 10.2.2.3, 00:19:10, FastEthernet1/0
C       10.2.2.0/24 is directly connected, FastEthernet1/0
C       10.1.1.0/24 is directly connected, FastEthernet0/0

■ R3의 Routing table

    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D       10.10.0.0/16 [90/30720] via 10.2.2.2, 00:20:42, FastEthernet0/0
C       10.10.10.0/24 is directly connected, FastEthernet1/0
C       10.2.2.0/24 is directly connected, FastEthernet0/0
D       10.1.1.0/24 [90/30720] via 10.2.2.2, 00:20:42, FastEthernet0/0

자! 설정과 확인이 끝났습니다.

여기서 R1에서 10.10.10.1로 Ping을 시도해 볼까요?

R1# ping 10.10.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

헉.. 안가네요. R2에서 시도해 볼까요?

R2# ping 10.10.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

허거덕! 자신의 Interface인데 Ping이 안가네요. 그럼 10.10.10.2로는 Ping이 갈까요?

R1# ping 10.10.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/112/184 ms

R2# ping 10.10.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/59/112 ms

흠... R1과 R2에서 정상적으로 Ping이 되는군요.
왜 이런 현상이 발생할까요? 멍청한 R2는 자신의 Interface로도 Ping을 보내지 못하고 있습니다.
정답은 월요일 메일링에서 상세한 설명과 함께 보내드리도록 하겠습니다. 고민해보세요! ^^

오늘의 LAB 문제를 마치도록 하겠습니다.

 

티스토리 툴바